Two nice and possibly very useful functions. But IMO the names 'mapp' and 'grepp' are two similar to 'map' and 'grep', making it prone to typos and misreading. Perhaps consider 'map2' and 'grep2'?
Easy to use, does what it says, and really helpful. The interface is similar to the language built-in
those name shortcuts are very convenient too. O(∩_∩)O~