List-MoreUtils reviews

RSS | Module Info

List-MoreUtils (0.33) *****

This module is so vital to everyday use of Perl that it makes me wonder why oh why Perl comes bundled with modules that implement HTTP server push and NNTP, but doesn't come bundled with List-MoreUtils! Hell, the 'first' and 'uniq' functions should plain old be part of the Perl language itself.

List-MoreUtils (0.33) *****

very good for old version of Perl
I use instead of ~~
use Modern::Perl;
use List::MoreUtils qw(any);
my @list=qw{boots balls smelt};
my $search_value='balls';
my $not_found_value='gnome';

foreach my $sv($search_value,$not_found_value){
if (any { $_ eq $sv } @list) {

print "$sv found\n";


print "$sv not found\n";



List-MoreUtils (0.22) *****

Hugely useful list of utility functions that I find make my code easier to write, easier to read and faster.

Well documented. Does what it says it does.

List-MoreUtils (0.22) ****

I'm still discovering things to like about this module. For example "pairwise" is a nice thing to use until iterators come along:

@products = pairwise { $a * $b } @factors1, @factors2;

List-MoreUtils (0.22) *****

A hugely useful set of utility functions.

Not only do they make your code smaller, but in situations where you have lots of very tight iterative code with many many subroutine calls, they can also make your code significantly faster as well.

The only thing I wish it had would be to let me spell "uniq" as "distinct" in SQL style.

List-MoreUtils (0.18) ****

These are useful utilities, but I have a problem with the names of some of the functions.

"true" and "false" return counts of the number of true or false return values in code blocks operating on the lists. But reading code which uses them is confusing. One would expect them to return truth values, not numbers. A more intuitive name would be "count". (And one only needs a count-true method; false is easy to implement from that.)

One could nitpick about other function names, but they're not as critical.

List-MoreUtils (0.12) *****

If I were an array object, I would want these as my methods. They do all the things you hate writing over and over, and a bunch more things that you'll realize you should've been writing but never did. It makes List::Util look like a tinkertoy.