Reviews by

cpanratings
 

RSS

Net-SSH-Perl (1.24) *****

This is the first ssh for perl i could get to work!!

Temperature collection on a group of Sun Blades:
------------------------------------------------
use Net::SSH::Perl;

$test="testws1 testws2 testws3 testws4 testws5" ;

@nodename=split( ' ', $test );

foreach $hostname (@nodename) {

$ssh = Net::SSH::Perl->new($hostname, port => 22);

print "$hostname ";

$ssh->login("root", "XXXXXX");

chomp ( my $cmd = 'prtpicl -v -c temperature-sensor | grep Temperature | awk \'{ a = $2 ; getline ; b = $2 ; getline ; print "CPU:"a" CASE:"b}\'');

my($out, $err) = $ssh->cmd($cmd || "ls -l");

print $out;

$ssh->cmd("exit");
}

MODULES I WAS MISSING TO MAKE COMPILE WORK:

Scalar::Util .................ok
Crypt::DSA ...................** FAILED **
Crypt::DES ...................** FAILED **
Digest::SHA1 .................** FAILED **
Convert::PEM .................** FAILED **
String::CRC32 ................** FAILED **
Math::Pari ...................ok
Digest::HMAC_SHA1 ............** FAILED **
Digest::HMAC_MD5 .............** FAILED **
IO::Socket ...................ok
MIME::Base64 .................ok
Digest::MD5 ..................ok
Crypt::DH ....................** FAILED **
Math::GMP ....................ok
Net::SSH::Perl depends on several external modules for functionality.
Some of these modules can not be found on your system; they can be
installed automatically for you. To do so will require loading the
CPAN shell, which may require you to be running as root. Answer 'n' to
each of the following questions if you'd rather not install any
needed modules right now; note, however, that you'll still need to
install them to use Net::SSH::Perl.

I had to compile the ** FAILED ** to get working on Solaris 8 SPARC.
It took a while, but the Net-SSH-Perl works stand alone, with out regular ssh on machine!

chanslor - 2003-11-21T18:04:39 (permalink)

4 out of 4 found this review helpful. Was this review helpful to you?  Yes No

GDGraph (1.43) *****

4 months into Perl, these modules are easy to use and look great!
On redhat 9 i had to upgrade my version on gd before perl gdgraph would complie....

chanslor - 2003-10-03T06:48:16 (permalink)

0 out of 2 found this review helpful. Was this review helpful to you?  Yes No