I agree, it's a horrible choice of a package name.
Please remove this from CPAN. Having a package called "package" is going to break all sorts of things.
This is silly. Top level package names that aren't exceptionally useful are bad enough, but to call it 'package' is stupifyingly idiotic.