I hate to give a module a "lousy namespace" review, but...
1. There is a Term::ReadPassword module already, so a Term::ReadPasswd module is confusing.
2. It's a Win32-specific module. So it should be called something like Win32::Term::ReadPassword, or Term::ReadPassword::Win32.
That said, despite the tests of Term::Readpassword failing in reports on Win32 machines, I recall getting it to work on Win32 when I used windows. I'm not 100% sure of this and no longer use Windows, but I'm skeptical of the need for a separate module just for Windows. I am sure that there already are modules which allow one to read from the console without echoing the keystrokes, even if it isn't Term::ReadPassword.